summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2014-12-07 18:25:28 (GMT)
committerKonstantin Podsvirov <konstantin@podsvirov.pro>2015-07-07 05:11:09 (GMT)
commit938bbc4352cf34532dc1f52998ec7d23532df765 (patch)
tree4a3c726707f16d8fd6b8ec885ab1847bbc277b65 /Source/CMakeLists.txt
parentfd23fc57115d21ad08da6b131ec9abe141e583e5 (diff)
downloadCMake-938bbc4352cf34532dc1f52998ec7d23532df765.zip
CMake-938bbc4352cf34532dc1f52998ec7d23532df765.tar.gz
CMake-938bbc4352cf34532dc1f52998ec7d23532df765.tar.bz2
CMake: Install COMPONENTs
Added components: - cmake - ctest - cpack - cmake-gui - ccmake - data - sphinx-html - sphinx-singlehtml - sphinx-qthelp Other now Unspecified.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 6d012fd..83d3090 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -734,9 +734,16 @@ endif()
include (${CMake_BINARY_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
include (${CMake_SOURCE_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
-install(TARGETS cmake ctest cpack DESTINATION bin)
+# Install tools
+
+set(_tools cmake ctest cpack)
+
if(APPLE)
- install(TARGETS cmakexbuild DESTINATION bin)
+ list(APPEND _tools cmakexbuild)
endif()
+foreach(_tool ${_tools})
+ install(TARGETS ${_tool} DESTINATION bin COMPONENT ${_tool})
+endforeach()
+
install(FILES cmCPluginAPI.h DESTINATION ${CMAKE_DATA_DIR}/include)