summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-04-22 13:19:06 (GMT)
committerBrad King <brad.king@kitware.com>2009-04-22 13:19:06 (GMT)
commit9c17cbeb44f4e47dd8f6a2cda57c3967b293cdfe (patch)
treef31f0e20ee3c74d471870b83e571c70c45ef6141 /Source/CMakeLists.txt
parentd25289ad9254c67d8231c6582b4b9a35daa8297c (diff)
downloadCMake-9c17cbeb44f4e47dd8f6a2cda57c3967b293cdfe.zip
CMake-9c17cbeb44f4e47dd8f6a2cda57c3967b293cdfe.tar.gz
CMake-9c17cbeb44f4e47dd8f6a2cda57c3967b293cdfe.tar.bz2
ENH: Teach CTest to handle git repositories
This creates cmCTestGIT to drive CTest Update handling on git-based work trees. Currently we always update to the head of the remote tracking branch (git pull), so the nightly start time is ignored for Nightly builds. A later change will address this. See issue #6994.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index bcc5999..20d8c6b 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -361,6 +361,8 @@ SET(CTEST_SRCS cmCTest.cxx
CTest/cmCTestCVS.h
CTest/cmCTestSVN.cxx
CTest/cmCTestSVN.h
+ CTest/cmCTestGIT.cxx
+ CTest/cmCTestGIT.h
)
# Build CTestLib