summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-08-24 14:58:42 (GMT)
committerBrad King <brad.king@kitware.com>2015-08-27 17:35:13 (GMT)
commit92b835ec9d17b190b13da93702f0eb416b665a48 (patch)
treedfa13d914d79b889f5aef2f645b5a539b7d48c91 /Source/CMakeLists.txt
parent2370a99400c6450606e25562386cf40bc9c41f38 (diff)
downloadCMake-92b835ec9d17b190b13da93702f0eb416b665a48.zip
CMake-92b835ec9d17b190b13da93702f0eb416b665a48.tar.gz
CMake-92b835ec9d17b190b13da93702f0eb416b665a48.tar.bz2
Simplify condition for using rpcrt4 library on Windows
Drop the CMAKE_BUILD_ON_VISUAL_STUDIO variable and hard-code the condition at its only use.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 428b364..1886519 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -556,8 +556,8 @@ if(APPLE)
target_link_libraries(CMakeLib "-framework CoreFoundation")
endif()
-if(CMAKE_BUILD_ON_VISUAL_STUDIO OR MINGW)
- # We need the rpcrt4 library for at least the VS7-VC10 generators.
+if(WIN32 AND NOT UNIX)
+ # We need the rpcrt4 library on Windows.
target_link_libraries(CMakeLib rpcrt4)
endif()