summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-07-07 20:37:56 (GMT)
committerBrad King <brad.king@kitware.com>2015-07-09 13:50:05 (GMT)
commit001f9b361711b479ee0d530056e44b7444edfcff (patch)
tree480f5e333a21000e27c0e7042d3ac9fbdba9e8af /Source/CMakeLists.txt
parent6f6664f578426e15e6e101f20a0c54a7b2820e96 (diff)
downloadCMake-001f9b361711b479ee0d530056e44b7444edfcff.zip
CMake-001f9b361711b479ee0d530056e44b7444edfcff.tar.gz
CMake-001f9b361711b479ee0d530056e44b7444edfcff.tar.bz2
Add common base classes to Makefile and Ninja generators
Provide a place to move functionality common to both.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 6940187..d5fe7d1 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -165,6 +165,8 @@ set(SRCS
cmCommandArgumentLexer.cxx
cmCommandArgumentParser.cxx
cmCommandArgumentParserHelper.cxx
+ cmCommonTargetGenerator.cxx
+ cmCommonTargetGenerator.h
cmComputeComponentGraph.cxx
cmComputeComponentGraph.h
cmComputeLinkDepends.cxx
@@ -260,6 +262,8 @@ set(SRCS
cmGeneratorExpression.h
cmGeneratorTarget.cxx
cmGeneratorTarget.h
+ cmGlobalCommonGenerator.cxx
+ cmGlobalCommonGenerator.h
cmGlobalGenerator.cxx
cmGlobalGenerator.h
cmGlobalGeneratorFactory.h
@@ -285,6 +289,8 @@ set(SRCS
cmListFileCache.cxx
cmListFileCache.h
cmListFileLexer.c
+ cmLocalCommonGenerator.cxx
+ cmLocalCommonGenerator.h
cmLocalGenerator.cxx
cmLocalGenerator.h
cmLocalUnixMakefileGenerator3.cxx