summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2002-05-02 19:10:19 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2002-05-02 19:10:19 (GMT)
commit2242006ca1f6834059d23b761dafd4ad7e70661b (patch)
tree25234eab987916695cbe4202d2548b8c61def63e /Source/CMakeLists.txt
parent4fe8947bcc725396a6bb85720c6836d81d100dd7 (diff)
downloadCMake-2242006ca1f6834059d23b761dafd4ad7e70661b.zip
CMake-2242006ca1f6834059d23b761dafd4ad7e70661b.tar.gz
CMake-2242006ca1f6834059d23b761dafd4ad7e70661b.tar.bz2
Debug optimized cache fixes
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt17
1 files changed, 9 insertions, 8 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 0a27df0..589c52d 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -67,14 +67,6 @@ IF (WIN32)
ENDIF(NOT UNIX)
ENDIF (WIN32)
-IF (UNIX)
- INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)
- IF (CURSES_LIBRARY)
- SUBDIRS(CursesDialog/form)
- INCLUDE(${CMake_SOURCE_DIR}/Source/CursesDialog/CMakeLists.txt)
- ENDIF (CURSES_LIBRARY)
-ENDIF (UNIX)
-
SET(SRCS ${SRCS} cmUnixMakefileGenerator.cxx cmUnixMakefileGenerator.h)
@@ -91,6 +83,15 @@ ADD_EXECUTABLE(DumpDocumentation cmDumpDocumentation)
ADD_EXECUTABLE(ctest ctest.cxx cmSystemTools.cxx cmRegularExpression.cxx)
ADD_EXECUTABLE(ccommand ccommand.cxx cmSystemTools.cxx cmMakefile.cxx)
+
+IF (UNIX)
+ INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)
+ IF (CURSES_LIBRARY)
+ SUBDIRS(CursesDialog/form)
+ INCLUDE(${CMake_SOURCE_DIR}/Source/CursesDialog/CMakeLists.txt)
+ ENDIF (CURSES_LIBRARY)
+ENDIF (UNIX)
+
IF (NOT DART_ROOT)
SET(MAKEPROGRAM ${CMAKE_MAKE_PROGRAM})
ENDIF (NOT DART_ROOT)