summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2015-04-12 11:15:51 (GMT)
committerStephen Kelly <steveire@gmail.com>2015-06-06 07:15:55 (GMT)
commit6d7abb6326d422dabdf72e8486b492ac20f8b347 (patch)
tree0a174867b9a74cba8032edbe5ee4df4a0b4d57fd /Source/CMakeLists.txt
parenta82441572493e4f420fca24041b594da9d3c14e6 (diff)
downloadCMake-6d7abb6326d422dabdf72e8486b492ac20f8b347.zip
CMake-6d7abb6326d422dabdf72e8486b492ac20f8b347.tar.gz
CMake-6d7abb6326d422dabdf72e8486b492ac20f8b347.tar.bz2
cmOutputConverter: Extract from cmLocalGenerator.
The Convert methods never belonged to the local generator concept, so split them out now. The cmOutputConverter is cheap to construct and destroy, so it can be instantiated where needed to perform conversions. This will allow further decoupling of cmLocalGenerator from the configure step. Inherit cmLocalGenerator from cmOutputConverter for the purpose of source compatibility.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index a7adb51..b434327 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -299,6 +299,8 @@ set(SRCS
cmMakefileUtilityTargetGenerator.cxx
cmOSXBundleGenerator.cxx
cmOSXBundleGenerator.h
+ cmOutputConverter.cxx
+ cmOutputConverter.h
cmNewLineStyle.h
cmNewLineStyle.cxx
cmOrderDirectories.cxx