summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-12-13 14:58:30 (GMT)
committerKitware Robot <kwrobot@kitware.com>2018-12-13 14:58:50 (GMT)
commit0be5ed7128b59c6ac3b508fa89fe793f5cfdf07c (patch)
treec29f1443d50156e4c5f62ef149cff8bc27751458 /Source/CMakeLists.txt
parentdc90cd68778b374122162cd3a87a7b6d27ed6866 (diff)
parent2d68b2c593b0bc19273e95f98ff29b3d3cff90c7 (diff)
downloadCMake-0be5ed7128b59c6ac3b508fa89fe793f5cfdf07c.zip
CMake-0be5ed7128b59c6ac3b508fa89fe793f5cfdf07c.tar.gz
CMake-0be5ed7128b59c6ac3b508fa89fe793f5cfdf07c.tar.bz2
Merge topic 'custom-string'
2d68b2c593 String: Add str_if_stable() as a const alternative to str() a0841b59bd String: Add support for a ""_s string literal syntax 9d5fe8e96a String: Add 'borrow' member to construct borrowing instances 80802a002c String: Add support for concatenation by operator+ ff69763ca0 String: Add a custom string type 410a3e4b22 Add support for using C++17 string_view or a fallback Acked-by: Kitware Robot <kwrobot@kitware.com> Acked-by: Daniel Pfeifer <daniel@pfeifer-mail.de> Acked-by: Pavel Solodovnikov <hellyeahdominate@gmail.com> Merge-request: !2578
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index e86cc2f..91c45bc 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -383,6 +383,9 @@ set(SRCS
cmXMLWriter.h
cmake.cxx
cmake.h
+ cm_string_view.cxx
+ cm_string_view.hxx
+ cm_static_string_view.hxx
cmCommand.cxx
cmCommand.h
@@ -574,6 +577,8 @@ set(SRCS
cmSiteNameCommand.h
cmSourceGroupCommand.cxx
cmSourceGroupCommand.h
+ cmString.cxx
+ cmString.hxx
cmStringReplaceHelper.cxx
cmStringCommand.cxx
cmStringCommand.h