summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2007-03-19 17:04:10 (GMT)
committerKen Martin <ken.martin@kitware.com>2007-03-19 17:04:10 (GMT)
commit3abf39eda0f6e9e099e55a45ae61180d5c4acde3 (patch)
tree340594aae0f00464b6c57c14b4f7de5102274af6 /Source/CMakeLists.txt
parentfc7c43346318744d05829579e6312aecddc66207 (diff)
downloadCMake-3abf39eda0f6e9e099e55a45ae61180d5c4acde3.zip
CMake-3abf39eda0f6e9e099e55a45ae61180d5c4acde3.tar.gz
CMake-3abf39eda0f6e9e099e55a45ae61180d5c4acde3.tar.bz2
ENH: support for --build-config-sample feature #1022
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 4051da5..c7a55d8 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -653,11 +653,12 @@ IF(BUILD_TESTING)
SET(COMPILER_IS_COMO 1)
ENDIF(CMAKE_BASE_NAME MATCHES "^como$")
IF(NOT COMPILER_IS_COMO)
- ADD_TEST(complex ${CMAKE_CTEST_COMMAND}
+ ADD_TEST(complex ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/Complex"
"${CMake_BINARY_DIR}/Tests/Complex"
--build-two-config
+ --build-config-sample "${CMAKE_CTEST_COMMAND}"
--build-generator ${CMAKE_TEST_GENERATOR}
--build-project Complex
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}