summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-11-06 13:56:33 (GMT)
committerKitware Robot <kwrobot@kitware.com>2017-11-06 13:58:11 (GMT)
commit73db89c2c2d997f6e1992dd1eab05e54792bd164 (patch)
tree2f150b4c1058743f43c586fbef07594bd808b7a4 /Source/CMakeLists.txt
parent2dabcebf3ce1b331c723055322b3fbe2e8ab482d (diff)
parent39c2feaf8c4dcb9c3a30c68a066fb70e126d7fe6 (diff)
downloadCMake-73db89c2c2d997f6e1992dd1eab05e54792bd164.zip
CMake-73db89c2c2d997f6e1992dd1eab05e54792bd164.tar.gz
CMake-73db89c2c2d997f6e1992dd1eab05e54792bd164.tar.bz2
Merge topic 'server-refactor'
39c2feaf misc: Added utility method to allow working with stacks f5d2988e server: Swapped to cm_thread impl 2636d86c utility: Added minimal std::thread drop-in d46b4ba8 server: Updated server tests to try various communication channels 08dca583 Tests: reworked server tests to allow other operation modes Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !1230
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index f15dff8..a8d77b2 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -593,6 +593,7 @@ set(SRCS
cm_utf8.c
cm_codecvt.hxx
cm_codecvt.cxx
+ cm_thread.hxx
)
SET_PROPERTY(SOURCE cmProcessOutput.cxx APPEND PROPERTY COMPILE_DEFINITIONS