summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2007-11-16 12:01:58 (GMT)
committerDavid Cole <david.cole@kitware.com>2007-11-16 12:01:58 (GMT)
commit867de7fc670ffd67c9cb8dcffae42f87de7023ed (patch)
treefebaeb64e474158b5289f31853b20cdcb396fe43 /Source/CMakeLists.txt
parent0a001f1567dff13bb3441728b313b9fa7b2b1b11 (diff)
downloadCMake-867de7fc670ffd67c9cb8dcffae42f87de7023ed.zip
CMake-867de7fc670ffd67c9cb8dcffae42f87de7023ed.tar.gz
CMake-867de7fc670ffd67c9cb8dcffae42f87de7023ed.tar.bz2
ENH: Add ability to call Visual Studio macros from CMake. Add a CMake Visual Studio macro to reload a solution file automatically if CMake makes changes to .sln files or .vcproj files. Add code to call the macro automatically for any running Visual Studio instances with the .sln file open at the end of the Visual Studio Generate call. Only call the macro if some .sln or .vcproj file changed during Generate. Also, add handling for REG_EXPAND_SZ type to SystemTools::ReadRegistryValue - returned string has environment variable references expanded.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 86c4579..d4ec11a 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -208,6 +208,11 @@ ENDIF(APPLE)
IF (WIN32)
+ SET(SRCS ${SRCS}
+ cmCallVisualStudioMacro.cxx
+ cmCallVisualStudioMacro.h
+ )
+
IF(NOT UNIX)
SET(SRCS ${SRCS}
cmGlobalBorlandMakefileGenerator.cxx