summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2016-07-12 21:10:28 (GMT)
committerBrad King <brad.king@kitware.com>2016-07-13 14:02:12 (GMT)
commit8ae035a569a0e548ca52f042e468477886a53240 (patch)
tree3ee63121e013a59e1f32bd3da6e46265e0aaeadb /Source/CMakeLists.txt
parent53df6d5995bef4a4884ede870c7b904033395ce2 (diff)
downloadCMake-8ae035a569a0e548ca52f042e468477886a53240.zip
CMake-8ae035a569a0e548ca52f042e468477886a53240.tar.gz
CMake-8ae035a569a0e548ca52f042e468477886a53240.tar.bz2
CMake: install COMPONENT cmcldeps
Added in Tools group with IFW installer
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index d49ebbb..a790994 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -530,11 +530,14 @@ set(SRCS ${SRCS}
cmNinjaUtilityTargetGenerator.h
)
+# Temporary variable for tools targets
+set(_tools)
+
if(WIN32 AND NOT CYGWIN)
set_source_files_properties(cmcldeps.cxx PROPERTIES COMPILE_DEFINITIONS _WIN32_WINNT=0x0501)
add_executable(cmcldeps cmcldeps.cxx ${MANIFEST_FILE})
+ list(APPEND _tools cmcldeps)
target_link_libraries(cmcldeps CMakeLib)
- install(TARGETS cmcldeps DESTINATION bin)
endif()
foreach(v CURL_CA_BUNDLE CURL_CA_PATH)
@@ -746,6 +749,7 @@ endif()
if(APPLE)
add_executable(cmakexbuild cmakexbuild.cxx)
+ list(APPEND _tools cmakexbuild)
target_link_libraries(cmakexbuild CMakeLib)
add_executable(OSXScriptLauncher
CPack/OSXScriptLauncher.cxx)
@@ -755,14 +759,17 @@ endif()
# Build CMake executable
add_executable(cmake cmakemain.cxx cmcmd.cxx cmcmd.h ${MANIFEST_FILE})
+list(APPEND _tools cmake)
target_link_libraries(cmake CMakeLib)
# Build CTest executable
add_executable(ctest ctest.cxx ${MANIFEST_FILE})
+list(APPEND _tools ctest)
target_link_libraries(ctest CTestLib)
# Build CPack executable
add_executable(cpack CPack/cpack.cxx ${MANIFEST_FILE})
+list(APPEND _tools cpack)
target_link_libraries(cpack CPackLib)
# Curses GUI
@@ -781,15 +788,12 @@ include (${CMake_SOURCE_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
# Install tools
-set(_tools cmake ctest cpack)
-
-if(APPLE)
- list(APPEND _tools cmakexbuild)
-endif()
-
foreach(_tool ${_tools})
CMake_OPTIONAL_COMPONENT(${_tool})
install(TARGETS ${_tool} DESTINATION ${CMAKE_BIN_DIR} ${COMPONENT})
endforeach()
install(FILES cmCPluginAPI.h DESTINATION ${CMAKE_DATA_DIR}/include)
+
+# Unset temporary variables
+unset(_tools)