summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-12-08 02:08:17 (GMT)
committerBrad King <brad.king@kitware.com>2018-12-12 13:10:15 (GMT)
commita0841b59bdacc1e550e6607d9e44e79ae456cd19 (patch)
tree780f579afba03f7feb663889582889438d775e0a /Source/CMakeLists.txt
parent9d5fe8e96a074b6e112d981302c77e31a1bcde00 (diff)
downloadCMake-a0841b59bdacc1e550e6607d9e44e79ae456cd19.zip
CMake-a0841b59bdacc1e550e6607d9e44e79ae456cd19.tar.gz
CMake-a0841b59bdacc1e550e6607d9e44e79ae456cd19.tar.bz2
String: Add support for a ""_s string literal syntax
Create a `static_string_view` type that binds only to the static storage of string literals. Teach `cm::String` to borrow from these implicitly.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 0ce09d4..ab3e835 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -377,6 +377,7 @@ set(SRCS
cmake.h
cm_string_view.cxx
cm_string_view.hxx
+ cm_static_string_view.hxx
cmCommand.cxx
cmCommand.h