summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-07-21 15:53:23 (GMT)
committerBrad King <brad.king@kitware.com>2006-07-21 15:53:23 (GMT)
commitd56e6a9241df2244732e23b7dd88b94e8bef3a33 (patch)
tree49f66984758a8b3f50dac488326008f7cc8f0136 /Source/CMakeLists.txt
parent673e3f8964f124d65731a93fb5fdc8d6fa760ec4 (diff)
downloadCMake-d56e6a9241df2244732e23b7dd88b94e8bef3a33.zip
CMake-d56e6a9241df2244732e23b7dd88b94e8bef3a33.tar.gz
CMake-d56e6a9241df2244732e23b7dd88b94e8bef3a33.tar.bz2
BUG: Fixed building of C++-only projects and added a test.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ff49466..271f5f9 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -504,6 +504,16 @@ IF(BUILD_TESTING)
--build-two-config
--test-command conly)
+ ADD_TEST(CxxOnly ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/CxxOnly"
+ "${CMake_BINARY_DIR}/Tests/CxxOnly"
+ --build-generator ${CMAKE_TEST_GENERATOR}
+ --build-project cxxonly
+ --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
+ --build-two-config
+ --test-command cxxonly)
+
ADD_TEST(MacroTest ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/MacroTest"