summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-03-16 14:39:56 (GMT)
committerBrad King <brad.king@kitware.com>2009-03-16 14:39:56 (GMT)
commite67f5138b80b3b04844f3f5c0a3c69796266f9e6 (patch)
tree918dfffdd191602494e888ce72e3afaf797fbe9f /Source/CMakeLists.txt
parente30835345abd1d05891c383506cadbc08ec51ccf (diff)
downloadCMake-e67f5138b80b3b04844f3f5c0a3c69796266f9e6.zip
CMake-e67f5138b80b3b04844f3f5c0a3c69796266f9e6.tar.gz
CMake-e67f5138b80b3b04844f3f5c0a3c69796266f9e6.tar.bz2
ENH: Refactor cmInstallGenerator for re-use
A new cmScriptGenerator base class factors out the non-install-specific part of cmInstallGenerator. This will be useful for other generators that want per-configuration functionality.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index d977a46..89ee0ad 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -201,6 +201,8 @@ SET(SRCS
cmPropertyDefinitionMap.h
cmPropertyMap.cxx
cmPropertyMap.h
+ cmScriptGenerator.h
+ cmScriptGenerator.cxx
cmSourceFile.cxx
cmSourceFile.h
cmSourceFileLocation.cxx