summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-08-08 15:40:41 (GMT)
committerKyle Edwards <kyle.edwards@kitware.com>2019-08-09 14:42:02 (GMT)
commitd4d5053c308662b529c9a578258b18a54fdce6e5 (patch)
tree18972b27e4c60162cacc11cd78c9365636b640e0 /Source/CMakeLists.txt
parentfe921edd49f6acc37570f51f8ead3158069dfda4 (diff)
downloadCMake-d4d5053c308662b529c9a578258b18a54fdce6e5.zip
CMake-d4d5053c308662b529c9a578258b18a54fdce6e5.tar.gz
CMake-d4d5053c308662b529c9a578258b18a54fdce6e5.tar.bz2
Refactor: Finish replacing CMAKE_BUILD_WITH_CMAKE with CMAKE_BOOTSTRAP
Remove -DCMAKE_BUILD_WITH_CMAKE from Source/CMakeLists.txt. Remove CMAKE_BOOTSTRAP from bootstrap's cmConfigure.h. Add -DCMAKE_BOOTSTRAP to all bootstrap sources, and remove the Unix specialization of CMAKE_BOOTSTRAP in libuv (a review of the libuv code suggests that this will not have an effect on the Windows build.)
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ee82ff5..7cd07a8 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -95,9 +95,6 @@ include_directories(
${CMake_HAIKU_INCLUDE_DIRS}
)
-# let cmake know it is supposed to use it
-add_definitions(-DCMAKE_BUILD_WITH_CMAKE)
-
# Check if we can build the ELF parser.
if(CMAKE_USE_ELF_PARSER)
set(ELF_SRCS cmELF.h cmELF.cxx)