summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-09-20 14:38:15 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-09-20 14:38:43 (GMT)
commitebb9346490741ddc2ce6f552bc1be57dfc730cfa (patch)
tree63abd0be387f587977d0026affc0f901ac91e02e /Source/CMakeLists.txt
parentdf0586d8d5c99d870369f1f60f63431deb98a6ba (diff)
parent4a08690ccf01dc36d44a55d1645d8281909ea092 (diff)
downloadCMake-ebb9346490741ddc2ce6f552bc1be57dfc730cfa.zip
CMake-ebb9346490741ddc2ce6f552bc1be57dfc730cfa.tar.gz
CMake-ebb9346490741ddc2ce6f552bc1be57dfc730cfa.tar.bz2
Merge topic 'cmake-system-headers'
4a08690ccf cmstd: Extend header <cm/iterator> c688b401d3 cmstd: Modernize CMake system headers Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3776
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 7b580e5..8ed7b2f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -437,9 +437,6 @@ set(SRCS
cmXMLWriter.h
cmake.cxx
cmake.h
- cm_string_view.cxx
- cm_string_view.hxx
- cm_static_string_view.hxx
cmCommand.cxx
cmCommand.h
@@ -681,13 +678,13 @@ set(SRCS
cmWriteFileCommand.cxx
cmWriteFileCommand.h
+ cm_static_string_view.hxx
cm_get_date.h
cm_get_date.c
cm_utf8.h
cm_utf8.c
cm_codecvt.hxx
cm_codecvt.cxx
- cm_thread.hxx
cmDuration.h
cmDuration.cxx
@@ -853,6 +850,7 @@ endforeach()
# create a library used by the command line and the GUI
add_library(CMakeLib ${SRCS})
target_link_libraries(CMakeLib cmsys
+ ${CMAKE_STD_LIBRARY}
${CMAKE_EXPAT_LIBRARIES} ${CMAKE_ZLIB_LIBRARIES}
${CMAKE_TAR_LIBRARIES}
${CMAKE_CURL_LIBRARIES}