summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-11-05 16:29:13 (GMT)
committerBrad King <brad.king@kitware.com>2021-11-05 16:39:22 (GMT)
commit4ef974e6cb41537a2ab40ab02b684cb44e098794 (patch)
tree651f457febc1003e3395a6f8fa1fd13c507048e5 /Source/CMakeLists.txt
parent463e17b095d062011b8e44993558a95c02f09fb9 (diff)
downloadCMake-4ef974e6cb41537a2ab40ab02b684cb44e098794.zip
CMake-4ef974e6cb41537a2ab40ab02b684cb44e098794.tar.gz
CMake-4ef974e6cb41537a2ab40ab02b684cb44e098794.tar.bz2
CPack: Remove undocumented deprecated OSXX11 generator
This CPack generator was never documented, and has been deprecated since commit 2ed00e8ef8 (CPack: Deprecate OSXX11 generator, 2020-01-31, v3.17.0-rc1~45^2). Issue: #20235
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index c125378..677fd2f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -1109,7 +1109,6 @@ if(APPLE)
set(CPACK_SRCS ${CPACK_SRCS}
CPack/cmCPackBundleGenerator.cxx
CPack/cmCPackDragNDropGenerator.cxx
- CPack/cmCPackOSXX11Generator.cxx
CPack/cmCPackPKGGenerator.cxx
CPack/cmCPackPackageMakerGenerator.cxx
CPack/cmCPackProductBuildGenerator.cxx
@@ -1146,13 +1145,6 @@ if(CPACK_ENABLE_FREEBSD_PKG AND FREEBSD_PKG_INCLUDE_DIRS AND FREEBSD_PKG_LIBRARI
add_definitions(-DHAVE_FREEBSD_PKG)
endif()
-if(APPLE)
- add_executable(OSXScriptLauncher
- CPack/OSXScriptLauncher.cxx)
- target_link_libraries(OSXScriptLauncher cmsys)
- target_link_libraries(OSXScriptLauncher "-framework CoreFoundation")
-endif()
-
# Build CMake executable
add_executable(cmake cmakemain.cxx cmcmd.cxx cmcmd.h ${MANIFEST_FILE})
list(APPEND _tools cmake)