summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-03-07 16:44:48 (GMT)
committerBrad King <brad.king@kitware.com>2012-03-09 20:16:02 (GMT)
commit11d9b211266865f0ce4a1005bbb18748c0806bce (patch)
tree601872149fd07d7272cb27e45021349853a1fddf /Source/CMakeLists.txt
parent51b67366ed9d8e81567cfff1ede2b34d85410933 (diff)
downloadCMake-11d9b211266865f0ce4a1005bbb18748c0806bce.zip
CMake-11d9b211266865f0ce4a1005bbb18748c0806bce.tar.gz
CMake-11d9b211266865f0ce4a1005bbb18748c0806bce.tar.bz2
Add cmGeneratorTarget to represent a target during generation
Some per-target information and logic is common to all generators. Some of that information is currently stored in cmTarget but that should be reserved for the configure step. Create a class to hold per-target information for generators. On construction classify sources from the target and store them in separate members. This classification is already implemented separately in each generator.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 0c420b9..af74ead 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -185,6 +185,8 @@ SET(SRCS
cmGeneratedFileStream.cxx
cmGeneratorExpression.cxx
cmGeneratorExpression.h
+ cmGeneratorTarget.cxx
+ cmGeneratorTarget.h
cmGlobalGenerator.cxx
cmGlobalGenerator.h
cmGlobalUnixMakefileGenerator3.cxx