summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-02-24 15:40:18 (GMT)
committerBrad King <brad.king@kitware.com>2009-02-24 15:40:18 (GMT)
commit1936499250425a1d50d70759758c7385b4bdf6d4 (patch)
treeba467f3fdf79068f715b64eb6a72536d9cee2996 /Source/CMakeLists.txt
parent6bdc2b5d99313ab6418b07ff91320135907ac261 (diff)
downloadCMake-1936499250425a1d50d70759758c7385b4bdf6d4.zip
CMake-1936499250425a1d50d70759758c7385b4bdf6d4.tar.gz
CMake-1936499250425a1d50d70759758c7385b4bdf6d4.tar.bz2
ENH: Create cmProcessTools to parse child output
This class provides a RunProcess method to run a child process and send its output to an abstract parsing interface. This also provides a simple line parser and logger implementing the parsing interface.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 3180339..964099c 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -187,6 +187,8 @@ SET(SRCS
cmOrderDirectories.h
cmPolicies.h
cmPolicies.cxx
+ cmProcessTools.cxx
+ cmProcessTools.h
cmProperty.cxx
cmProperty.h
cmPropertyDefinition.cxx