summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2008-07-31 17:46:17 (GMT)
committerDavid Cole <david.cole@kitware.com>2008-07-31 17:46:17 (GMT)
commit33126856165eb7d3315b9320d8a2f3e15d89779c (patch)
treeb985074c71f21f490e44ecf4cd477f07d7ed75fa /Source/CMakeLists.txt
parent45b9a2d5750a7a0e6fa6041dd7eb928eae1b1f5f (diff)
downloadCMake-33126856165eb7d3315b9320d8a2f3e15d89779c.zip
CMake-33126856165eb7d3315b9320d8a2f3e15d89779c.tar.gz
CMake-33126856165eb7d3315b9320d8a2f3e15d89779c.tar.bz2
BUG: Fix issue #7058 - link the commsup lib explicitly for use on some Visual Studio + SDK combinations
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 516e208..140e427 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -302,6 +302,14 @@ IF(CMAKE_BUILD_ON_VISUAL_STUDIO OR MINGW)
TARGET_LINK_LIBRARIES(CMakeLib rpcrt4)
ENDIF(CMAKE_BUILD_ON_VISUAL_STUDIO OR MINGW)
+# With the Microsoft compiler (for _bstr_t support used from
+# cmCallVisualStudioMacro) we need the comsupp lib. Needed when
+# _MSC_VER and HAVE_COMDEF_H are defined...
+#
+IF(MSVC)
+ TARGET_LINK_LIBRARIES(CMakeLib optimized comsupp debug comsuppd)
+ENDIF(MSVC)
+
#
# CTestLib
#