summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-01-13 17:58:08 (GMT)
committerBrad King <brad.king@kitware.com>2010-01-13 17:58:08 (GMT)
commit5b5372059c655b8501ea842940627cf8516ca31d (patch)
tree5f66e8a916d8e2d2f44f57704649d5f18a217e83 /Source/CMakeLists.txt
parentfdbe16c1f4cc22422ae3d923834d4d956263e580 (diff)
downloadCMake-5b5372059c655b8501ea842940627cf8516ca31d.zip
CMake-5b5372059c655b8501ea842940627cf8516ca31d.tar.gz
CMake-5b5372059c655b8501ea842940627cf8516ca31d.tar.bz2
Enable extra CodeBlocks generator on Cygwin
This generator builds correctly on Cygwin so it should be enabled. Change based on patch from issue #10122.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 8e3872b..49cbda7 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -167,6 +167,8 @@ SET(SRCS
cmExportFileGenerator.cxx
cmExportInstallFileGenerator.h
cmExportInstallFileGenerator.cxx
+ cmExtraCodeBlocksGenerator.cxx
+ cmExtraCodeBlocksGenerator.h
cmExtraEclipseCDT4Generator.cxx
cmExtraEclipseCDT4Generator.h
cmFileTimeComparison.cxx
@@ -256,10 +258,6 @@ IF(UNIX)
SET(SRCS ${SRCS} cmGlobalKdevelopGenerator.cxx)
ENDIF(UNIX)
-IF(NOT CYGWIN)
- SET(SRCS ${SRCS} cmExtraCodeBlocksGenerator.cxx)
-ENDIF(NOT CYGWIN)
-
# XCode only works on apple
IF(APPLE)
SET(SRCS ${SRCS}