summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2019-03-13 15:54:01 (GMT)
committerSebastian Holtermann <sebholt@xwmw.org>2019-03-18 14:09:10 (GMT)
commit6f24c4e93f6ae897b793f894b67543d86c7de477 (patch)
tree0394dff24abf759349bcc6c2914b4fb126e394a4 /Source/CMakeLists.txt
parentb06f8c93e5bc65394fe55b3f7ae923fe296048b3 (diff)
downloadCMake-6f24c4e93f6ae897b793f894b67543d86c7de477.zip
CMake-6f24c4e93f6ae897b793f894b67543d86c7de477.tar.gz
CMake-6f24c4e93f6ae897b793f894b67543d86c7de477.tar.bz2
New cmFileTime class
The new cmFileTime class stores the file modification time as an OS independent nanosecond count. Its main use is to load and compare file modification times in nanosecond and second resolution.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 696826f..140754c 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -236,6 +236,8 @@ set(SRCS
cmFileLockResult.h
cmFilePathChecksum.cxx
cmFilePathChecksum.h
+ cmFileTime.cxx
+ cmFileTime.h
cmFileTimeComparison.cxx
cmFileTimeComparison.h
cmFortranParserImpl.cxx
@@ -796,6 +798,8 @@ foreach(check
else()
set(CMake_${check} 0)
endif()
+ set_property(SOURCE cmFileTime.cxx APPEND PROPERTY
+ COMPILE_DEFINITIONS CMake_${check}=${CMake_${check}})
set_property(SOURCE cmFileTimeComparison.cxx APPEND PROPERTY
COMPILE_DEFINITIONS CMake_${check}=${CMake_${check}})
endforeach()