summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Coppa <dcoppa@openbsd.org>2013-06-21 09:13:35 (GMT)
committerBrad King <brad.king@kitware.com>2013-06-21 12:27:40 (GMT)
commit480e924daedee520d18c8a9c0b9823fef205b57a (patch)
tree854bc7b1ef667ea8939717b1e1431d1edbbc7654 /Source/CMakeLists.txt
parent9f160c5b0a7e0f821ca4737638edbebf0ed398be (diff)
downloadCMake-480e924daedee520d18c8a9c0b9823fef205b57a.zip
CMake-480e924daedee520d18c8a9c0b9823fef205b57a.tar.gz
CMake-480e924daedee520d18c8a9c0b9823fef205b57a.tar.bz2
OpenBSD: Enable ELF parsing and editing (#14241)
OpenBSD provides ELF ABI declarations in #include <stdint.h> #include <elf_abi.h> Teach the platform check and cmELF implementation to use these.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 1893167..67a6333 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -11,7 +11,11 @@
#=============================================================================
include(CheckIncludeFile)
# Check if we can build support for ELF parsing.
-CHECK_INCLUDE_FILE("elf.h" HAVE_ELF_H)
+if(CMAKE_CXX_PLATFORM_ID MATCHES "OpenBSD")
+ CHECK_INCLUDE_FILES("stdint.h;elf_abi.h" HAVE_ELF_H)
+else()
+ CHECK_INCLUDE_FILE("elf.h" HAVE_ELF_H)
+endif()
if(HAVE_ELF_H)
set(CMAKE_USE_ELF_PARSER 1)
else()