summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-16 13:28:12 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-10-16 13:28:12 (GMT)
commitc49083e9a4cddbdc6cbcc582e2d8d5fc7cfd7740 (patch)
tree96102c69673467ce7b922697cd5f378511249201 /Source/CMakeLists.txt
parent5029da5eac08171653a92b961c341f7ffcca3640 (diff)
parent7038a93a7eafa83d506dd73bed171dc72dfbd9a5 (diff)
downloadCMake-c49083e9a4cddbdc6cbcc582e2d8d5fc7cfd7740.zip
CMake-c49083e9a4cddbdc6cbcc582e2d8d5fc7cfd7740.tar.gz
CMake-c49083e9a4cddbdc6cbcc582e2d8d5fc7cfd7740.tar.bz2
Merge topic 'doc-reStructuredText'
7038a93 Modules/readme.txt: Update steps to add module documentation a77e308 CPack: Replace #<type> markup with reStructuredText equivalent e7ca48f Help: Factor out cmake-generator-expressions manual page 97e8650 Help: Factor out COMPILE_DEFINITIONS disclaimer duplication 8982161 Help: Factor out find_* command duplication 30b2186 Help: Factor out *_OUTPUT_(NAME|DIRECTORY).rst duplication bfe07aa Build Help documentation during CMake build using Sphinx 53ded59 Drop unused builtin documentation APIs 0c39a75 Drop the 'Full' field from cmDocumentationEntry e33d8d2 Drop builtin command documentation 399e9c4 Drop builtin property documentation 6035c04 get_property: Drop test for builtin property documentation 80a3273 Drop all documentation formatters except Usage b336a1eb Teach COMPATIBLE_INTERFACE_* checks to use Help .rst documents ec6df36 Teach --help-* options to load documentation from .rst files 25f2877 Add class cmRST to do basic reStructuredText processing ...
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 9b81e8b..71fae58 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -159,16 +159,7 @@ set(SRCS
cmDependsJavaParserHelper.h
cmDocumentation.cxx
cmDocumentationFormatter.cxx
- cmDocumentationFormatterHTML.cxx
- cmDocumentationFormatterDocbook.cxx
- cmDocumentationFormatterMan.cxx
- cmDocumentationFormatterText.cxx
- cmDocumentationFormatterUsage.cxx
cmDocumentationSection.cxx
- cmDocumentCompileDefinitions.h
- cmDocumentGeneratorExpressions.h
- cmDocumentLocationUndefined.h
- cmDocumentVariables.cxx
cmDynamicLoader.cxx
cmDynamicLoader.h
${ELF_SRCS}
@@ -261,6 +252,8 @@ set(SRCS
cmPropertyMap.h
cmQtAutomoc.cxx
cmQtAutomoc.h
+ cmRST.cxx
+ cmRST.h
cmScriptGenerator.h
cmScriptGenerator.cxx
cmSourceFile.cxx
@@ -497,8 +490,6 @@ set(CPACK_SRCS
CPack/cmCPackTarBZip2Generator.cxx
CPack/cmCPackTarCompressGenerator.cxx
CPack/cmCPackZIPGenerator.cxx
- CPack/cmCPackDocumentVariables.cxx
- CPack/cmCPackDocumentMacros.cxx
)
if(CYGWIN)