summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Levermann <simon-github@slevermann.de>2015-10-19 09:13:55 (GMT)
committerBrad King <brad.king@kitware.com>2015-11-06 16:14:49 (GMT)
commitf88533cc067ea252254b0851d87f09ef798e2c97 (patch)
tree78686375daa00b36fa167de4b3fde5faf3b39431 /Source/CMakeLists.txt
parent13dc7bdb5e3a0eaaf3607b154bba77a01404a788 (diff)
downloadCMake-f88533cc067ea252254b0851d87f09ef798e2c97.zip
CMake-f88533cc067ea252254b0851d87f09ef798e2c97.tar.gz
CMake-f88533cc067ea252254b0851d87f09ef798e2c97.tar.bz2
CPackDMG: Add support for multilingual SLAs
Multiple languages for SLAs and the SLA UI can be added via the CPack variables CPACK_DMG_SLA_DIR and CPACK_DMG_SLA_LANGUAGES. For each language defined in the languages variable, CPack will search for <language>.menu.txt and <language>.license.txt in CPACK_DMG_SLA_DIR. If the sla directory variable is not defined, the old behaviour using CPACK_RESOURCE_FILE_LICENSE is retained.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index fd71b0e..f23331b 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -726,6 +726,9 @@ endif()
# Build CPackLib
add_library(CPackLib ${CPACK_SRCS})
target_link_libraries(CPackLib CMakeLib)
+if(APPLE)
+ target_link_libraries(CPackLib "-framework Carbon")
+endif()
if(APPLE)
add_executable(cmakexbuild cmakexbuild.cxx)