summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorIyyappa Murugandi <iyyappam@microsoft.com>2016-12-15 02:53:30 (GMT)
committerBrad King <brad.king@kitware.com>2016-12-16 14:58:43 (GMT)
commit18c8278b622e4cb9b155c5dc4ceac93322bed85f (patch)
tree796d86bf7385c3b4f2ea71d090c67d9540c59e15 /Source/CMakeLists.txt
parentd47bda00b2e46b3fd6f9e050f3f21b5337ac244b (diff)
downloadCMake-18c8278b622e4cb9b155c5dc4ceac93322bed85f.zip
CMake-18c8278b622e4cb9b155c5dc4ceac93322bed85f.tar.gz
CMake-18c8278b622e4cb9b155c5dc4ceac93322bed85f.tar.bz2
VS: Add helper class to interact with Visual Studio Installer
VS 2017 exports a COM component which can be queried to find if VS 2017 is installed and also other components such as VC toolset and Windows SDKs. Add a helper class to interact with this interface.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index d15fdbe..57b7b25 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -710,6 +710,8 @@ if (WIN32)
cmGhsMultiTargetGenerator.h
cmGhsMultiGpj.cxx
cmGhsMultiGpj.h
+ cmVSSetupHelper.cxx
+ cmVSSetupHelper.h
)
# Add a manifest file to executables on Windows to allow for