summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Richardson <Alexander.Richardson@cl.cam.ac.uk>2021-06-17 14:22:34 (GMT)
committerBrad King <brad.king@kitware.com>2021-06-24 14:57:51 (GMT)
commit115ff6a347a96eb77abcd8df5e72e4851dcea414 (patch)
tree925a33815ef6168c56eeec955ac4f356256ddf64 /Source/CMakeLists.txt
parent5dfa3ddbe592add43e2985dad772f6aa44d37c0b (diff)
downloadCMake-115ff6a347a96eb77abcd8df5e72e4851dcea414.zip
CMake-115ff6a347a96eb77abcd8df5e72e4851dcea414.tar.gz
CMake-115ff6a347a96eb77abcd8df5e72e4851dcea414.tar.bz2
cmELF: Include the ELF parsing code unconditionally
Now that the ELF definitions are provided on all platforms there is no need to keep the CMake_USE_ELF_PARSER option.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 39e4a9d..6446b04 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -11,8 +11,6 @@ endif()
include(CheckIncludeFile)
-set(CMake_USE_ELF_PARSER 1)
-
if(NOT CMake_DEFAULT_RECURSION_LIMIT)
if(DEFINED ENV{DASHBOARD_TEST_FROM_CTEST})
set(CMake_DEFAULT_RECURSION_LIMIT 100)
@@ -83,11 +81,6 @@ include_directories(
${CMake_HAIKU_INCLUDE_DIRS}
)
-# The ELF parser can be built on all platforms.
-if(CMake_USE_ELF_PARSER)
- set(ELF_SRCS cmELF.h cmELF.cxx)
-endif()
-
# Check if we can build the Mach-O parser.
if(CMake_USE_MACH_PARSER)
set(MACH_SRCS cmMachO.h cmMachO.cxx)
@@ -217,7 +210,8 @@ set(SRCS
cmDocumentationSection.cxx
cmDynamicLoader.cxx
cmDynamicLoader.h
- ${ELF_SRCS}
+ cmELF.h
+ cmELF.cxx
cmExprParserHelper.cxx
cmExportBuildAndroidMKGenerator.h
cmExportBuildAndroidMKGenerator.cxx