summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-01-26 16:54:41 (GMT)
committerBrad King <brad.king@kitware.com>2021-01-28 14:07:00 (GMT)
commit32498d0665dfb49ecb9d88790f83c6ca3e75e2b4 (patch)
tree644e071c96f6e056a678c48ea63dfc4ba14360f8 /Source/CMakeLists.txt
parent87909f0600f635a86ae4152868e7fed51d502d3d (diff)
downloadCMake-32498d0665dfb49ecb9d88790f83c6ca3e75e2b4.zip
CMake-32498d0665dfb49ecb9d88790f83c6ca3e75e2b4.tar.gz
CMake-32498d0665dfb49ecb9d88790f83c6ca3e75e2b4.tar.bz2
cmake: Reduce default recursion depth when compiling with IntelLLVM
This compiler makes stack frames large enough (at least in Debug builds) that CMake language recursion to depth 1000 overflows the stack. Reduce the limit for this compiler.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index dca94ee..b3d8369 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -46,6 +46,8 @@ if(NOT CMake_DEFAULT_RECURSION_LIMIT)
set(CMake_DEFAULT_RECURSION_LIMIT 100)
elseif(MINGW)
set(CMake_DEFAULT_RECURSION_LIMIT 400)
+ elseif(WIN32 AND CMAKE_C_COMPILER_ID STREQUAL "IntelLLVM")
+ set(CMake_DEFAULT_RECURSION_LIMIT 600)
else()
set(CMake_DEFAULT_RECURSION_LIMIT 1000)
endif()