summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2004-05-04 18:24:25 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2004-05-04 18:24:25 (GMT)
commit22de04fab9d440126e2b215291ae4ae3a6d91639 (patch)
tree82bdbdeba7241fb404115df9c34ae98cd3e9aabd /Source/CMakeLists.txt
parentee897e6a3c3ef2b20d0bb0d06e33201be597926e (diff)
downloadCMake-22de04fab9d440126e2b215291ae4ae3a6d91639.zip
CMake-22de04fab9d440126e2b215291ae4ae3a6d91639.tar.gz
CMake-22de04fab9d440126e2b215291ae4ae3a6d91639.tar.bz2
ENH: fix tests to work with in source builds
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index d38c37f..37c7897 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -263,7 +263,7 @@ IF(BUILD_TESTING)
--test-command ${SimpleInstallInstallDir}/bin/SimpleInstall)
ADD_TEST(SimpleInstall-Stage2 ${CMAKE_CTEST_COMMAND}
--build-and-test
- "${CMake_SOURCE_DIR}/Tests/SimpleInstall"
+ "${CMake_SOURCE_DIR}/Tests/SimpleInstallS2"
"${CMake_BINARY_DIR}/Tests/SimpleInstallS2"
--build-generator ${CMAKE_GENERATOR}
--build-project TestSimpleInstall
@@ -296,7 +296,7 @@ IF(BUILD_TESTING)
ADD_TEST(LoadedCommandOneConfig ${CMAKE_CTEST_COMMAND}
--build-and-test
- "${CMake_SOURCE_DIR}/Tests/LoadCommand"
+ "${CMake_SOURCE_DIR}/Tests/LoadCommandOneConfig"
"${CMake_BINARY_DIR}/Tests/LoadCommandOneConfig"
--build-generator ${CMAKE_GENERATOR}
--build-project LoadedCommand
@@ -324,7 +324,7 @@ IF(BUILD_TESTING)
ADD_TEST(complexOneConfig ${CMAKE_CTEST_COMMAND}
--build-and-test
- "${CMake_SOURCE_DIR}/Tests/Complex"
+ "${CMake_SOURCE_DIR}/Tests/ComplexOneConfig"
"${CMake_BINARY_DIR}/Tests/ComplexOneConfig"
--build-generator ${CMAKE_GENERATOR}
--build-project complex
@@ -334,7 +334,7 @@ IF(BUILD_TESTING)
ADD_TEST(complexRelativePaths ${CMAKE_CTEST_COMMAND}
--build-and-test
- "${CMake_SOURCE_DIR}/Tests/Complex"
+ "${CMake_SOURCE_DIR}/Tests/ComplexRelativePaths"
"${CMake_BINARY_DIR}/Tests/ComplexRelativePaths"
--build-generator ${CMAKE_GENERATOR}
--build-project complex