summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2004-04-23 16:52:48 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2004-04-23 16:52:48 (GMT)
commit8b0b749a11138107189f9264494f828778c0cf8b (patch)
tree08419721f7f8169515c3ebf1bb7cae6179c935e8 /Source/CMakeLists.txt
parenteae3d4cf0679212099204db7dc40514a28b1c493 (diff)
downloadCMake-8b0b749a11138107189f9264494f828778c0cf8b.zip
CMake-8b0b749a11138107189f9264494f828778c0cf8b.tar.gz
CMake-8b0b749a11138107189f9264494f828778c0cf8b.tar.bz2
ENH: add SUBDIR PREORDER and fix clean for non-relative paths
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 3ba2ff1..13b2416 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -228,6 +228,16 @@ IF(BUILD_TESTING)
--build-two-config
--test-command simple)
+ ADD_TEST(PreOrder ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/PreOrder"
+ "${CMake_BINARY_DIR}/Tests/PreOrder"
+ --build-generator ${CMAKE_GENERATOR}
+ --build-project PreOrder
+ --build-makeprogram ${MAKEPROGRAM}
+ --build-two-config
+ --test-command simple)
+
ADD_TEST(conly ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/COnly"