summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorGilles Khouzam <gillesk@microsoft.com>2015-08-21 21:15:38 (GMT)
committerBrad King <brad.king@kitware.com>2015-08-27 17:35:18 (GMT)
commitac0bb4333d13e633e26d107f288162d7d6a37b3a (patch)
tree469045dc2e7aa66efe3da92cf3b8832e1ba3dbd0 /Source/CMakeLists.txt
parent92b835ec9d17b190b13da93702f0eb416b665a48 (diff)
downloadCMake-ac0bb4333d13e633e26d107f288162d7d6a37b3a.zip
CMake-ac0bb4333d13e633e26d107f288162d7d6a37b3a.tar.gz
CMake-ac0bb4333d13e633e26d107f288162d7d6a37b3a.tar.bz2
VS: Windows Store/Phone package cert thumbprint
Add the PackageCertificateThumbprint property when there is a certificate on a WindowsStore or Phone app.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 1886519..16b9ea1 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -558,7 +558,8 @@ endif()
if(WIN32 AND NOT UNIX)
# We need the rpcrt4 library on Windows.
- target_link_libraries(CMakeLib rpcrt4)
+ # We need the crypt32 library on Windows for crypto/cert APIs.
+ target_link_libraries(CMakeLib rpcrt4 crypt32)
endif()
#