summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-12-07 04:05:10 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2006-12-07 04:05:10 (GMT)
commit26b527ac0fd63d2a86d3552122bd44a5b32d6adb (patch)
tree1d512054b9db82a4dd45aa839faf29fd737f6ae0 /Source/CMakeLists.txt
parenta44ac0719ca0919aec649fec7a9b8e592b925b0b (diff)
downloadCMake-26b527ac0fd63d2a86d3552122bd44a5b32d6adb.zip
CMake-26b527ac0fd63d2a86d3552122bd44a5b32d6adb.tar.gz
CMake-26b527ac0fd63d2a86d3552122bd44a5b32d6adb.tar.bz2
ENH: fix bug in full path to target depends stuff
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 9896b17..5311c72 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -410,16 +410,17 @@ IF(BUILD_TESTING)
--test-command ${CMAKE_CMAKE_COMMAND} -E compare_files
${CMake_SOURCE_DIR}/Tests/TargetName/scripts/hello_world
${CMake_BINARY_DIR}/Tests/TargetName/scripts/hello_world)
- ADD_TEST(LibName ${CMAKE_CTEST_COMMAND}
+
+ ADD_TEST(CustComDepend ${CMAKE_CTEST_COMMAND}
--build-and-test
- "${CMake_SOURCE_DIR}/Tests/LibName"
- "${CMake_BINARY_DIR}/Tests/LibName"
+ "${CMake_SOURCE_DIR}/Tests/CustComDepend"
+ "${CMake_BINARY_DIR}/Tests/CustComDepend"
--build-two-config
--build-generator ${CMAKE_TEST_GENERATOR}
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
- --build-project LibName
- --build-exe-dir "${CMake_BINARY_DIR}/Tests/LibName/lib"
- --test-command foobar
+ --build-project CustComDepend
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/CustComDepend/bin"
+ --test-command foo bar.c
)
ADD_TEST(CustomCommand ${CMAKE_CTEST_COMMAND}