summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Turbov <i.zaufi@gmail.com>2022-08-21 05:05:53 (GMT)
committerBrad King <brad.king@kitware.com>2022-09-22 14:21:38 (GMT)
commit9cdf5a67790ef78292366268af0a3de4b5cc3892 (patch)
tree52629400536620bc90d03083d8d9150120ec4bf6 /Source/CMakeLists.txt
parent2be5a7de4ea987649dfc1ac669928fecf2613046 (diff)
downloadCMake-9cdf5a67790ef78292366268af0a3de4b5cc3892.zip
CMake-9cdf5a67790ef78292366268af0a3de4b5cc3892.tar.gz
CMake-9cdf5a67790ef78292366268af0a3de4b5cc3892.tar.bz2
Build: Use imported target `EXPAT::EXPAT` instead of variables
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 3edaabb..93b3f0c 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -743,7 +743,6 @@ target_include_directories(
"${CMake_BINARY_DIR}/Source"
"${CMake_SOURCE_DIR}/Source"
"${CMake_SOURCE_DIR}/Source/LexerParser"
- ${CMAKE_EXPAT_INCLUDES}
${CMAKE_TAR_INCLUDES}
${CMake_HAIKU_INCLUDE_DIRS}
)
@@ -752,8 +751,8 @@ target_link_libraries(
PUBLIC
cmstd
cmsys
+ EXPAT::EXPAT
ZLIB::ZLIB
- ${CMAKE_EXPAT_LIBRARIES}
${CMAKE_TAR_LIBRARIES}
${CMAKE_CURL_LIBRARIES}
${CMAKE_JSONCPP_LIBRARIES}