summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-09-19 16:00:09 (GMT)
committerBrad King <brad.king@kitware.com>2009-09-19 16:00:09 (GMT)
commitd4cfb77ffe816f71d456dc70ab18efb7eb19d82d (patch)
tree87908f67a85c448de02380c7078db623084ead8a /Source/CMakeLists.txt
parent180c60a86f5c44085a1a66865bfc8b9479c72e8a (diff)
downloadCMake-d4cfb77ffe816f71d456dc70ab18efb7eb19d82d.zip
CMake-d4cfb77ffe816f71d456dc70ab18efb7eb19d82d.tar.gz
CMake-d4cfb77ffe816f71d456dc70ab18efb7eb19d82d.tar.bz2
Remove cmGlobalXCode21Generator subclass
This subclass of cmGlobalXCodeGenerator only provided two virtual method overrides, and it made construction of the Xcode generator instance complicated. This commit removes it and replaces the virtual methods with tests of the Xcode version. The change removes duplicate code.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index eb1caaf..3849e9f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -251,8 +251,6 @@ IF(APPLE)
cmXCode21Object.cxx
cmGlobalXCodeGenerator.cxx
cmGlobalXCodeGenerator.h
- cmGlobalXCode21Generator.cxx
- cmGlobalXCode21Generator.h
cmLocalXCodeGenerator.cxx
cmLocalXCodeGenerator.h)
ENDIF(APPLE)