summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-01-21 09:26:42 (GMT)
committerBrad King <brad.king@kitware.com>2020-01-28 16:16:11 (GMT)
commitf8c505d4b30aa636b013486913591060b2040716 (patch)
tree2853577d4c09ff8f11dac45bfd4ba8a2a014dc90 /Source/CMakeLists.txt
parent306328ace87376dddb2a42bf33c6338aac5d09ad (diff)
downloadCMake-f8c505d4b30aa636b013486913591060b2040716.zip
CMake-f8c505d4b30aa636b013486913591060b2040716.tar.gz
CMake-f8c505d4b30aa636b013486913591060b2040716.tar.bz2
Add a parser for GCC-style depfiles
Introduce the function cmReadGccDepfile that parses a GCC-style depfile and returns its content. The implementation uses a lexer that is modeled after the re2c implementation in Ninja. The sample files of the autotest have been created with gcc 8.3.0. This depfile reader is to be used by the Autogen facility to make use of the depfiles that are generated by Qt's meta object compiler.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ff313d6..c57f713 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -134,6 +134,9 @@ set(SRCS
LexerParser/cmFortranParser.cxx
LexerParser/cmFortranParserTokens.h
LexerParser/cmFortranParser.y
+ LexerParser/cmGccDepfileLexer.cxx
+ LexerParser/cmGccDepfileLexer.h
+ LexerParser/cmGccDepfileLexer.in.l
LexerParser/cmListFileLexer.c
LexerParser/cmListFileLexer.in.l
@@ -270,6 +273,10 @@ set(SRCS
cmFortranParserImpl.cxx
cmFSPermissions.cxx
cmFSPermissions.h
+ cmGccDepfileLexerHelper.cxx
+ cmGccDepfileLexerHelper.h
+ cmGccDepfileReader.cxx
+ cmGccDepfileReader.h
cmGeneratedFileStream.cxx
cmGeneratorExpressionContext.cxx
cmGeneratorExpressionContext.h