summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Turbov <i.zaufi@gmail.com>2022-08-21 05:02:56 (GMT)
committerBrad King <brad.king@kitware.com>2022-09-22 14:20:30 (GMT)
commit2be5a7de4ea987649dfc1ac669928fecf2613046 (patch)
tree07a80293018d221034857320e90d43745a183814 /Source/CMakeLists.txt
parent14b94f9bf2e8ada7508ae0a248f376746c18d29c (diff)
downloadCMake-2be5a7de4ea987649dfc1ac669928fecf2613046.zip
CMake-2be5a7de4ea987649dfc1ac669928fecf2613046.tar.gz
CMake-2be5a7de4ea987649dfc1ac669928fecf2613046.tar.bz2
Build: Use imported target `ZLIB::ZLIB` instead of variables
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 9357fdf..3edaabb 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -743,7 +743,6 @@ target_include_directories(
"${CMake_BINARY_DIR}/Source"
"${CMake_SOURCE_DIR}/Source"
"${CMake_SOURCE_DIR}/Source/LexerParser"
- ${CMAKE_ZLIB_INCLUDES}
${CMAKE_EXPAT_INCLUDES}
${CMAKE_TAR_INCLUDES}
${CMake_HAIKU_INCLUDE_DIRS}
@@ -753,8 +752,8 @@ target_link_libraries(
PUBLIC
cmstd
cmsys
+ ZLIB::ZLIB
${CMAKE_EXPAT_LIBRARIES}
- ${CMAKE_ZLIB_LIBRARIES}
${CMAKE_TAR_LIBRARIES}
${CMAKE_CURL_LIBRARIES}
${CMAKE_JSONCPP_LIBRARIES}