summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-08-25 13:17:59 (GMT)
committerKitware Robot <kwrobot@kitware.com>2021-08-25 13:18:11 (GMT)
commit67d0d8b9d56291c16b4364b8b5371d78c3b14262 (patch)
tree09fc2cba6a728d89607bda74fb85845385341904 /Source/CMakeLists.txt
parente7fe4633b785af8ca34f5ca6a1e2b20406110206 (diff)
parentbf09145eb0cfc80068441631d0b106cc7948cff3 (diff)
downloadCMake-67d0d8b9d56291c16b4364b8b5371d78c3b14262.zip
CMake-67d0d8b9d56291c16b4364b8b5371d78c3b14262.tar.gz
CMake-67d0d8b9d56291c16b4364b8b5371d78c3b14262.tar.bz2
Merge topic 'darwin-wmake-jwasm-support'
bf09145eb0 Enable Watcom WMake generator on Darwin 78f758a463 Use dashes for MASM flags Acked-by: Kitware Robot <kwrobot@kitware.com> Tested-by: buildbot <buildbot@kitware.com> Merge-request: !6472
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 7e37141..8dc44a0 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -801,7 +801,7 @@ if (WIN32)
endif ()
# Watcom support
-if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Linux")
+if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Linux" OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set_property(SOURCE cmake.cxx APPEND PROPERTY COMPILE_DEFINITIONS CMAKE_USE_WMAKE)
list(APPEND SRCS
cmGlobalWatcomWMakeGenerator.cxx