summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBryon Bean <bryon.bean@kitware.com>2019-03-13 15:51:12 (GMT)
committerBrad King <brad.king@kitware.com>2019-03-13 18:06:32 (GMT)
commite2e8f6b132967844a8bafc866d6cb5c90342af08 (patch)
tree1535349b1d7539c9a307469d7dbeaf4ab2cde2e1 /Source/CMakeLists.txt
parent80b761b9244d5ab9047082be40ebeee256be95ef (diff)
downloadCMake-e2e8f6b132967844a8bafc866d6cb5c90342af08.zip
CMake-e2e8f6b132967844a8bafc866d6cb5c90342af08.tar.gz
CMake-e2e8f6b132967844a8bafc866d6cb5c90342af08.tar.bz2
cmFileCommand: Factor out cmFileCopier and cmFileInstaller
Split these classes out into their own sources.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 2db276d..696826f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -224,6 +224,10 @@ set(SRCS
cmFileAPICodemodel.h
cmFileAPICMakeFiles.cxx
cmFileAPICMakeFiles.h
+ cmFileCopier.cxx
+ cmFileCopier.h
+ cmFileInstaller.cxx
+ cmFileInstaller.h
cmFileLock.cxx
cmFileLock.h
cmFileLockPool.cxx