summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-08 20:43:55 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-08 20:43:55 (GMT)
commite4beefeb6dcc9637355a83efb89cb0c3c7fb44fd (patch)
treec28669e4dba5074de35f379fc5cebe38264cc94b /Source/CMakeLists.txt
parent5872cc7c1f0b41e7b9cfe7060ef88bc69daf8219 (diff)
downloadCMake-e4beefeb6dcc9637355a83efb89cb0c3c7fb44fd.zip
CMake-e4beefeb6dcc9637355a83efb89cb0c3c7fb44fd.tar.gz
CMake-e4beefeb6dcc9637355a83efb89cb0c3c7fb44fd.tar.bz2
CTest: Do not munge UTF-8 output in XML files
CTest filters the output from tools and tests to ensure that the XML build/test result documents it generates have valid characters. Previously we just converted all non-ASCII bytes into XML-escaped Unicode characters of the corresponding index. This does not preserve tool output encoded in UTF-8. We now assume UTF-8 output from tools and implement decoding as specified in RFC 3629. Valid characters are preserved, possibly with XML escaping. Invalid byte sequences and characters are converted to human-readable hex values with distinguishing tags. See issue #10003.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 2bfb777..621ac3e 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -246,6 +246,9 @@ SET(SRCS
cmake.h
cmakewizard.cxx
cmakewizard.h
+
+ cm_utf8.h
+ cm_utf8.c
)
# Kdevelop only works on UNIX and not windows