summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-09-06 17:10:55 (GMT)
committerBrad King <brad.king@kitware.com>2018-09-07 12:57:51 (GMT)
commitfc7e4d1ed85370d03acbd62bc753cced3550752b (patch)
tree25e5d5719b2da65398e7d2f0fbc4cb490e4428ff /Source/CMakeLists.txt
parentf782759ed0997eb3d71e1187a829da62668ed5d2 (diff)
downloadCMake-fc7e4d1ed85370d03acbd62bc753cced3550752b.zip
CMake-fc7e4d1ed85370d03acbd62bc753cced3550752b.tar.gz
CMake-fc7e4d1ed85370d03acbd62bc753cced3550752b.tar.bz2
cmLinkItem: Convert to a "sum type" over a string and target pointer
Avoid exposing the item name implicitly as std::string. When the item is a target, avoid storing a second copy of its name. Most link item construction is paired with calls to `FindTargetToLink` to get the possible target pointer. Rename these methods to `ResolveLinkItem` and refactor them to construct the entire item.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 0457984..628cc6f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -265,6 +265,7 @@ set(SRCS
cmInstallDirectoryGenerator.h
cmInstallDirectoryGenerator.cxx
cmLinkedTree.h
+ cmLinkItem.cxx
cmLinkItem.h
cmLinkLineComputer.cxx
cmLinkLineComputer.h