summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Turbov <i.zaufi@gmail.com>2022-08-21 06:01:34 (GMT)
committerBrad King <brad.king@kitware.com>2022-09-22 14:21:39 (GMT)
commit9629be8080d054ab44603802923a3ce72620f864 (patch)
treeb2ad38435be9b4f8506571f094770778266e5a78 /Source/CMakeLists.txt
parente6fb5a1febde8a30e578f08e04887c6e4e5511b4 (diff)
downloadCMake-9629be8080d054ab44603802923a3ce72620f864.zip
CMake-9629be8080d054ab44603802923a3ce72620f864.tar.gz
CMake-9629be8080d054ab44603802923a3ce72620f864.tar.bz2
Build: Use `CMAKE_CURRENT_XXX_DIR` instead of top dirs
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index fe04641..32bd341 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -740,9 +740,9 @@ target_include_directories(
CMakeLib
PUBLIC
# add the include path to find the .h
- "${CMake_BINARY_DIR}/Source"
- "${CMake_SOURCE_DIR}/Source"
- "${CMake_SOURCE_DIR}/Source/LexerParser"
+ "${CMAKE_CURRENT_BINARY_DIR}"
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ "${CMAKE_CURRENT_SOURCE_DIR}/LexerParser"
${CMake_HAIKU_INCLUDE_DIRS}
)
target_link_libraries(
@@ -1001,7 +1001,7 @@ add_library(
target_include_directories(
CTestLib
PUBLIC
- "${CMake_SOURCE_DIR}/Source/CTest"
+ "${CMAKE_CURRENT_SOURCE_DIR}/CTest"
)
target_link_libraries(CTestLib PUBLIC CMakeLib)
@@ -1175,8 +1175,8 @@ if(BUILD_QtDialog)
add_subdirectory(QtDialog)
endif()
-include(${CMake_BINARY_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
-include(${CMake_SOURCE_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
+include(${CMAKE_CURRENT_BINARY_DIR}/LocalUserOptions.cmake OPTIONAL)
+include(${CMAKE_CURRENT_SOURCE_DIR}/LocalUserOptions.cmake OPTIONAL)
if(WIN32)
# Compute the binary version that appears in the RC file. Version