summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorIsuru Fernando <isuruf@gmail.com>2019-11-23 04:04:52 (GMT)
committerBrad King <brad.king@kitware.com>2019-12-06 14:30:25 (GMT)
commit5ff1d7bd906bcbb831f87824ed5111f0a47d6b68 (patch)
tree73442e972f59e0880a45031a3d7da21086382e5f /Source/CMakeLists.txt
parent07226324ebd179a22cf581f31be07b71ab160ce6 (diff)
downloadCMake-5ff1d7bd906bcbb831f87824ed5111f0a47d6b68.zip
CMake-5ff1d7bd906bcbb831f87824ed5111f0a47d6b68.tar.gz
CMake-5ff1d7bd906bcbb831f87824ed5111f0a47d6b68.tar.bz2
Add support for WINDOWS_EXPORT_ALL_SYMBOLS when cross-compiling to Windows
Implement `__create_def` using `llvm-nm` (when given as `CMAKE_NM`).
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index d050fb7..ff313d6 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -693,6 +693,8 @@ set(SRCS
cmDuration.h
cmDuration.cxx
+
+ bindexplib.cxx
)
SET_PROPERTY(SOURCE cmProcessOutput.cxx APPEND PROPERTY COMPILE_DEFINITIONS
@@ -715,7 +717,6 @@ if (WIN32)
set(SRCS ${SRCS}
cmCallVisualStudioMacro.cxx
cmCallVisualStudioMacro.h
- bindexplib.cxx
)
if(NOT UNIX)