summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Kuemmel <syntheticpp@gmx.net>2012-02-19 18:15:57 (GMT)
committerPeter Kuemmel <syntheticpp@gmx.net>2012-02-19 18:15:57 (GMT)
commit3b847415154b13e401bf9f71042578ad21c9c1c9 (patch)
tree1072a7a66916e01e03b9bed69c93ef8183969952 /Source/CMakeLists.txt
parentadb54f3dbf802f643c8af9f8de6f67f24804dd22 (diff)
downloadCMake-3b847415154b13e401bf9f71042578ad21c9c1c9.zip
CMake-3b847415154b13e401bf9f71042578ad21c9c1c9.tar.gz
CMake-3b847415154b13e401bf9f71042578ad21c9c1c9.tar.bz2
Ninja: disable unfinished Windows ninja support
This way the branch is ready-to-merge, even when the generator is broken on Windows.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt32
1 files changed, 15 insertions, 17 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index a53a0c1..3ae9464 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -353,23 +353,21 @@ IF (WIN32)
ENDIF(NOT UNIX)
ENDIF (WIN32)
-SET(SRCS ${SRCS}
- cmGlobalNinjaGenerator.cxx
- cmGlobalNinjaGenerator.h
- cmNinjaTypes.h
- cmLocalNinjaGenerator.cxx
- cmLocalNinjaGenerator.h
- cmNinjaTargetGenerator.cxx
- cmNinjaTargetGenerator.h
- cmNinjaNormalTargetGenerator.cxx
- cmNinjaNormalTargetGenerator.h
- cmNinjaUtilityTargetGenerator.cxx
- cmNinjaUtilityTargetGenerator.h
- )
-ADD_DEFINITIONS(-DCMAKE_USE_NINJA)
-IF(WIN32)
- # TODO remove
- ADD_DEFINITIONS(-DENABLE_WIN32_NINJA_HACKS)
+if(NOT WIN32)
+ SET(SRCS ${SRCS}
+ cmGlobalNinjaGenerator.cxx
+ cmGlobalNinjaGenerator.h
+ cmNinjaTypes.h
+ cmLocalNinjaGenerator.cxx
+ cmLocalNinjaGenerator.h
+ cmNinjaTargetGenerator.cxx
+ cmNinjaTargetGenerator.h
+ cmNinjaNormalTargetGenerator.cxx
+ cmNinjaNormalTargetGenerator.h
+ cmNinjaUtilityTargetGenerator.cxx
+ cmNinjaUtilityTargetGenerator.h
+ )
+ ADD_DEFINITIONS(-DCMAKE_USE_NINJA)
endif()
# create a library used by the command line and the GUI