summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-12-02 13:21:12 (GMT)
committerBrad King <brad.king@kitware.com>2020-12-02 13:21:12 (GMT)
commitbdfa5ac7f6cfc961665064f1b7a1395cfd0b2281 (patch)
tree9f9c8f4ef0db863fb6adc0ae70891477d66d1cdb /Source/CMakeLists.txt
parentf7ff0d34f0750387f5c56483ab6ba3fb4825b62d (diff)
parent628d7ef67258f67e0b4086905011d90727d8b9a1 (diff)
downloadCMake-bdfa5ac7f6cfc961665064f1b7a1395cfd0b2281.zip
CMake-bdfa5ac7f6cfc961665064f1b7a1395cfd0b2281.tar.gz
CMake-bdfa5ac7f6cfc961665064f1b7a1395cfd0b2281.tar.bz2
Merge branch 'master' into llvm-rc-preprocess-as-c
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt21
1 files changed, 7 insertions, 14 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ca56d3a..c3b7e50 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -227,6 +227,8 @@ set(SRCS
cmDependsJava.h
cmDependsJavaParserHelper.cxx
cmDependsJavaParserHelper.h
+ cmDependsCompiler.cxx
+ cmDependsCompiler.h
cmDocumentation.cxx
cmDocumentationFormatter.cxx
cmDocumentationSection.cxx
@@ -444,6 +446,8 @@ set(SRCS
cmTest.h
cmTestGenerator.cxx
cmTestGenerator.h
+ cmTransformDepfile.cxx
+ cmTransformDepfile.h
cmUuid.cxx
cmUVHandlePtr.cxx
cmUVHandlePtr.h
@@ -508,6 +512,8 @@ set(SRCS
cmCMakeLanguageCommand.h
cmCMakeMinimumRequired.cxx
cmCMakeMinimumRequired.h
+ cmCMakePathCommand.h
+ cmCMakePathCommand.cxx
cmCMakePolicyCommand.cxx
cmCMakePolicyCommand.h
cmConditionEvaluator.cxx
@@ -833,6 +839,7 @@ endif()
# Ninja support
set(SRCS ${SRCS}
+ cmScanDepFormat.cxx
cmGlobalNinjaGenerator.cxx
cmGlobalNinjaGenerator.h
cmNinjaTypes.h
@@ -1157,20 +1164,6 @@ add_executable(cmake cmakemain.cxx cmcmd.cxx cmcmd.h ${MANIFEST_FILE})
list(APPEND _tools cmake)
target_link_libraries(cmake CMakeLib)
-add_library(CMakeServerLib
- cmConnection.h cmConnection.cxx
- cmFileMonitor.cxx cmFileMonitor.h
- cmJsonObjectDictionary.h
- cmJsonObjects.h
- cmJsonObjects.cxx
- cmPipeConnection.cxx cmPipeConnection.h
- cmServer.cxx cmServer.h
- cmServerConnection.cxx cmServerConnection.h
- cmServerProtocol.cxx cmServerProtocol.h
- )
-target_link_libraries(CMakeServerLib CMakeLib)
-target_link_libraries(cmake CMakeServerLib)
-
# Build CTest executable
add_executable(ctest ctest.cxx ${MANIFEST_FILE})
list(APPEND _tools ctest)