summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-07-08 13:19:12 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-07-08 13:19:12 (GMT)
commit66e0681ea0293aac6f3547224cef85593cbe4595 (patch)
tree9d209bd5f14f0037cd66d0aee2ab9180ec12e9ab /Source/CMakeLists.txt
parent8c1460653e8f21b9e09324617836aeec18f350b7 (diff)
parent9ce7a663d6d50c6f2d7a3fbc76ed10c5af6a91a5 (diff)
downloadCMake-66e0681ea0293aac6f3547224cef85593cbe4595.zip
CMake-66e0681ea0293aac6f3547224cef85593cbe4595.tar.gz
CMake-66e0681ea0293aac6f3547224cef85593cbe4595.tar.bz2
Merge topic 'cmake-install-components'
9ce7a663 Utilities/Sphinx: Add CMake_OPTIONAL_COMPONENT macro d7725a17 CMake: Add cmakexbuild component as REQUIRED to Tools group for IFW installer ecca2685 CMake: optional show LGPLv2.1 license when install cmake-gui component c14f20f7 CMake: Fix Web Site shortcut in IFW installer for Windows c823f04e CMake: New option CMake_INSTALL_COMPONENTS 7383e4d7 CMake: Install COMPONENTs (sphinx-man) 2531b909 CMake: Install COMPONENTs (QtDialog) 938bbc43 CMake: Install COMPONENTs
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 069f283..6940187 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -735,9 +735,17 @@ endif()
include (${CMake_BINARY_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
include (${CMake_SOURCE_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
-install(TARGETS cmake ctest cpack DESTINATION bin)
+# Install tools
+
+set(_tools cmake ctest cpack)
+
if(APPLE)
- install(TARGETS cmakexbuild DESTINATION bin)
+ list(APPEND _tools cmakexbuild)
endif()
+foreach(_tool ${_tools})
+ CMake_OPTIONAL_COMPONENT(${_tool})
+ install(TARGETS ${_tool} DESTINATION bin ${COMPONENT})
+endforeach()
+
install(FILES cmCPluginAPI.h DESTINATION ${CMAKE_DATA_DIR}/include)