summaryrefslogtreecommitdiffstats
path: root/Source/CTest/Curl/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2003-05-16 19:15:42 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2003-05-16 19:15:42 (GMT)
commit083aba04cfe2dba29b267100f52d2387f35dd487 (patch)
tree70d74e022901bc1aa34ed01be127c9fe6c80b982 /Source/CTest/Curl/CMakeLists.txt
parentb524f7573bcc09249006a529ba8c1e2aba8283f4 (diff)
downloadCMake-083aba04cfe2dba29b267100f52d2387f35dd487.zip
CMake-083aba04cfe2dba29b267100f52d2387f35dd487.tar.gz
CMake-083aba04cfe2dba29b267100f52d2387f35dd487.tar.bz2
ERR: Attempt to remove more warnings
Diffstat (limited to 'Source/CTest/Curl/CMakeLists.txt')
-rw-r--r--Source/CTest/Curl/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/Source/CTest/Curl/CMakeLists.txt b/Source/CTest/Curl/CMakeLists.txt
index 88ddc4a..1592112 100644
--- a/Source/CTest/Curl/CMakeLists.txt
+++ b/Source/CTest/Curl/CMakeLists.txt
@@ -416,5 +416,7 @@ IF(CURL_TESTING)
SUBDIRS(Testing)
ENDIF(CURL_TESTING)
-ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
-TARGET_LINK_LIBRARIES(LIBCURL Curl)
+IF(NOT CMAKE_BUILD_WITH_CURL)
+ ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
+ TARGET_LINK_LIBRARIES(LIBCURL Curl)
+ENDIF(NOT CMAKE_BUILD_WITH_CURL)