summaryrefslogtreecommitdiffstats
path: root/Source/CursesDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-08-27 13:01:14 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-08-27 13:01:14 (GMT)
commitc41f7983838a654c830edc94470be4defd0f1686 (patch)
tree648a0b4cf71d39365430d5667db3964f404ef461 /Source/CursesDialog/CMakeLists.txt
parenta764593f1d4f67d9b89d0a128c6cd69114097865 (diff)
downloadCMake-c41f7983838a654c830edc94470be4defd0f1686.zip
CMake-c41f7983838a654c830edc94470be4defd0f1686.tar.gz
CMake-c41f7983838a654c830edc94470be4defd0f1686.tar.bz2
COMP: make it build on NetBSD, which has separate curses and ncurses, so
it has to be detected that curses isn't good enough, but ncurses is, and that ncurses.h instead of curses.h is included Alex
Diffstat (limited to 'Source/CursesDialog/CMakeLists.txt')
-rw-r--r--Source/CursesDialog/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/Source/CursesDialog/CMakeLists.txt b/Source/CursesDialog/CMakeLists.txt
index bf86e1f..58a1c68 100644
--- a/Source/CursesDialog/CMakeLists.txt
+++ b/Source/CursesDialog/CMakeLists.txt
@@ -14,15 +14,14 @@ SET( CURSES_SRCS
CursesDialog/ccmake
)
-INCLUDE_DIRECTORIES(${CMake_SOURCE_DIR}/Source/CursesDialog/form)
+INCLUDE_DIRECTORIES(${CMake_SOURCE_DIR}/Source/CursesDialog/form
+ ${CMake_BINARY_DIR}/Source/CursesDialog/form)
LINK_DIRECTORIES(${CMake_BINARY_DIR}/Source/CursesDialog/form)
INCLUDE_DIRECTORIES(${CURSES_INCLUDE_PATH})
-
-
ADD_EXECUTABLE(ccmake ${CURSES_SRCS} )
TARGET_LINK_LIBRARIES(ccmake CMakeLib)
TARGET_LINK_LIBRARIES(ccmake cmForm)
-INSTALL_TARGETS(/bin ccmake) \ No newline at end of file
+INSTALL_TARGETS(/bin ccmake)