summaryrefslogtreecommitdiffstats
path: root/Source/CursesDialog/form/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2005-04-21 21:00:36 (GMT)
committerBrad King <brad.king@kitware.com>2005-04-21 21:00:36 (GMT)
commit2f4e516e230c179cdf7c488f4101aae3a52ac53b (patch)
tree82a887d59ae00122aed6c0089e8fe2f943e555f5 /Source/CursesDialog/form/CMakeLists.txt
parentcf8a3a15213ab4b3014c1dd148be48a46d3e4f67 (diff)
downloadCMake-2f4e516e230c179cdf7c488f4101aae3a52ac53b.zip
CMake-2f4e516e230c179cdf7c488f4101aae3a52ac53b.tar.gz
CMake-2f4e516e230c179cdf7c488f4101aae3a52ac53b.tar.bz2
COMP: Using a new work-around for stdarg.h problem on SGI.
Diffstat (limited to 'Source/CursesDialog/form/CMakeLists.txt')
-rw-r--r--Source/CursesDialog/form/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/CursesDialog/form/CMakeLists.txt b/Source/CursesDialog/form/CMakeLists.txt
index 618aef2..2ec21ec 100644
--- a/Source/CursesDialog/form/CMakeLists.txt
+++ b/Source/CursesDialog/form/CMakeLists.txt
@@ -50,3 +50,8 @@ TARGET_LINK_LIBRARIES(cmForm ${CURSES_LIBRARY})
IF(CURSES_EXTRA_LIBRARY)
TARGET_LINK_LIBRARIES(cmForm ${CURSES_EXTRA_LIBRARY})
ENDIF(CURSES_EXTRA_LIBRARY)
+
+# See internal_stdio_core.h.in for explanation.
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/internal_stdio_core.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/internal/stdio_core.h
+ @ONLY IMMEDIATE)