summaryrefslogtreecommitdiffstats
path: root/Source/FLTKDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-06-19 20:10:38 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-06-19 20:10:38 (GMT)
commitd6836427b34230c9cc87412d45fc74fc8aeec2c1 (patch)
treea01f31b7bab7f3ef3617ed0f9ac509528dea47ed /Source/FLTKDialog/CMakeLists.txt
parent016cc41e6e9843c07fd7918a3b3e46ce9e995b95 (diff)
downloadCMake-d6836427b34230c9cc87412d45fc74fc8aeec2c1.zip
CMake-d6836427b34230c9cc87412d45fc74fc8aeec2c1.tar.gz
CMake-d6836427b34230c9cc87412d45fc74fc8aeec2c1.tar.bz2
ENH: build fltk cmake on unix with bootstrap
Diffstat (limited to 'Source/FLTKDialog/CMakeLists.txt')
-rw-r--r--Source/FLTKDialog/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Source/FLTKDialog/CMakeLists.txt b/Source/FLTKDialog/CMakeLists.txt
index 761a896..d110cd8 100644
--- a/Source/FLTKDialog/CMakeLists.txt
+++ b/Source/FLTKDialog/CMakeLists.txt
@@ -7,6 +7,7 @@ FLTKPropertyList
FLTKPropertyNameButtonWithHelp
)
+
LINK_LIBRARIES(${FLTK_LIBRARY})
IF(WIN32)
IF(NOT UNIX)
@@ -14,6 +15,12 @@ IF(WIN32)
ENDIF(NOT UNIX)
ENDIF(WIN32)
+
+IF(UNIX)
+ INCLUDE (${CMAKE_ROOT}/Modules/FindOpenGL.cmake)
+ LINK_LIBRARIES(${OPENGL_LIBRARY})
+ENDIF(UNIX)
+
INCLUDE_DIRECTORIES(${FLTK_INCLUDE_PATH})
ADD_EXECUTABLE(CMakeSetupDialog SRCS)