summaryrefslogtreecommitdiffstats
path: root/Source/FLTKDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2005-09-23 21:47:46 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2005-09-23 21:47:46 (GMT)
commit46521aef8cf2523990dfbf90dbdf435a94f8e5c4 (patch)
tree7da33dc6434184423e86b635357cfda4632e5d38 /Source/FLTKDialog/CMakeLists.txt
parentf7d926d072a6582237282ef9a3302c8a1e8e94b1 (diff)
downloadCMake-46521aef8cf2523990dfbf90dbdf435a94f8e5c4.zip
CMake-46521aef8cf2523990dfbf90dbdf435a94f8e5c4.tar.gz
CMake-46521aef8cf2523990dfbf90dbdf435a94f8e5c4.tar.bz2
ENH: try to find a gui for the Mac
Diffstat (limited to 'Source/FLTKDialog/CMakeLists.txt')
-rw-r--r--Source/FLTKDialog/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/Source/FLTKDialog/CMakeLists.txt b/Source/FLTKDialog/CMakeLists.txt
new file mode 100644
index 0000000..3f585d7
--- /dev/null
+++ b/Source/FLTKDialog/CMakeLists.txt
@@ -0,0 +1,24 @@
+FIND_PACKAGE(FLTK)
+
+SET(SRCS
+CMakeSetupGUIImplementation.cxx
+FLTKDialog.cxx
+FLTKPropertyItemRow.cxx
+FLTKPropertyList.cxx
+)
+
+SET(FLTK_GUI_Files_SRCS
+CMakeSetupGUI.fl
+)
+
+
+LINK_LIBRARIES(${FLTK_LIBRARY})
+
+
+INCLUDE_DIRECTORIES(${FLTK_INCLUDE_PATH})
+
+FLTK_WRAP_UI(FLCMakeSetup ${FLTK_GUI_Files_SRCS})
+
+ADD_EXECUTABLE(FLCMakeSetup ${SRCS} ${FLCMakeSetup_FLTK_SRCS})
+TARGET_LINK_LIBRARIES(FLCMakeSetup CMakeLib)
+